Внешняя компонента для преобразования файлов из/в кодировку Base64 из встроенного языка 1С Предприятие

Base64.dll

Внешняя компонента для преобразования файлов из/в кодировку Base64 из встроенного языка 1С Предприятие.

Методы объекта Addin.Base64:

EncodeBase64, ЗакодироватьBase64(FileName) – можно обращаться к методу в русском или английском варианте

Читает файл FileName.
Преобразует этот файл в закодированную base64 строку.

Параметры: FileName – имя файла
Возвращаемое значение: закодированная base64 строка.

DecodeBase64, РаскодироватьBase64(FileName) – можно обращаться к методу в русском или английском варианте

Читает файл FileName.
Преобразует этот файл в обычную строку.

Параметры: FileName – имя файла
Возвращаемое значение: обычная строка

Для работы с компонентой скопируйте файл Base64.dll, например в каталог базы данных.

В конфигураторе используйте функцию ЗагрузитьВнешнююКомпоненту:

Процедура ПриОткрытии()
	Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "Base64.dll")=0 Тогда
		Сообщить("Не удается загрузить Base64.dll!");
		Возврат;
	Иначе
		Сообщить("Удалось загрузить Base64.dll!");	
	КонецЕсли;
КонецПроцедуры	// ПриОткрытии

// Преобразует файл в Base64 строку
Функция Base64(ПутьКФайлу)
	Попытка
		ВК = СоздатьОбъект("AddIn.Base64");
	Исключение
		Сообщить("Не удается создать объект AddIn.Base64!");
		а=1/0;
	КонецПопытки;
	СтрокаИзФайла = ВК.ЗакодироватьBase64(ПутьКФайлу);
	Возврат СтрокаИзФайла;
КонецФункции	// Base64

В этой статье Вы найдёте пример работы с внешней компонентой Base64. Понравилась ли вам статья? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!

0 ответы

Ответить

Want to join the discussion?
Feel free to contribute!

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *