Обработка для установки главного узла базы 1С 8

Форма обработки 1С8 установки главного узла распределенной информационной базы

Доброго времени суток, уважаемые читатели нашего блога! Выкладываю небольшую обработку,
установки главного узла базы 1С 8. Обычно, функционал этой обработки помогает, когда необходимо, что бы ваша база из периферийной стала центральной или наоборот, вам нужно подчинить или назначить вашей базе главный узел распределенной информационной базы (РИБ). Практическое применение этой обработки для исправления ошибок обмена здесь.

В прошлый раз была выложена неплохая обработка для копирования файлов и папок напрямую из 1С 8, а также обработка для
загрузки штрихкодов из Excel
.

Содержание

Внешний вид обработки для назначения главного узла базы:

Форма обработки 1С8 установки главного узла распределенной информационной базы


Описание работы обработки установки главного узла базы

Работа с этой обработкой не составляет большого труда.

  • Скачайте обработку по ссылке в конце статьи.
  • Затем откройте её

    в режиме 1С:Предприятие 8
    .
  • Перейдите к пункту меню «Файл» | «Открыть…» (Ctrl+O).
  • После открытия, на форме обработки появится надпись, указывающая является ли текущая база узлом распределенной информационной базы. Если текущая информационная база является узлом распределенной информационной базы, то вы увидите следующую надпись:
    		«Главный узел:  Название вашего узла»
    	
  • Читать/смотреть далее

Обработка для копирования файлов и папок из 1С 8

Форма обработки 1С8 копирования файлов и папок

Доброго времени суток, уважаемые читатели нашего блога! Я хочу поделиться небольшой обработкой,
для копирования файлов и папок из 1С, с указанием некоторого условия. Мне она пригодилась для переноса файлов и папок из папки Dropbox, в которой среди важных для меня файлов, скопилось много ненужных мне файлов с расширением «dropbox.attributes». Задача стояла перенести только мои файлы без этого хлама, сохранив при этом иерархию папок.

Также вы можете скачать другие обработки для 1С 8, перейдя по ссылкам
здесь, а
отчёты для 1С 8 тут.
С помощью одной из обработок вы сможете

удалить задублированные элементы в справочнике «Контрагенты»
.
Другая обработка поможет тем, кто работает в конфигурации УТП, она предназначена для

загрузки штрихкодов из Excel
.

Содержание

Внешний вид обработки копирования файлов и папок из 1С:


Форма обработки 1С8 копирования файлов и папок


Описание работы обработки копирования файлов и папок

Читать/смотреть далее

Обработка 1С для загрузки штрихкодов из Excel для УТП

Форма обработки 1С8 загрузка штрихкодов из Excel для УТП

Здравствуйте, уважаемые читатели блога SoftMaker.kz! В прошлый раз здесь была опубликована для загрузки обработка распределения времени, которая помогает тем, кто хочет быстро распределить время сотрудников. Сегодня будет размещена обработка, которая поможет быстро загрузить штрихкоды в информационную базу конфигурации Управление Торговым Предприятием.

Содержание

Внешний вид обработки загрузка штрихкодов из Excel для УТП следующий:


Форма обработки 1С8 загрузка штрихкодов из Excel для УТП


Описание работы обработки загрузка штрихкодов из Excel для УТП

Читать/смотреть далее

Обработка 1С распределения времени сотрудников в таблице значений

Форма обработки 1С8 распределения времени сотрудников

Здравствуйте, уважаемые читатели блога SoftMaker.kz! Не так давно я опубликовал статью, в которой привел ряд примеров программирования с таблицей значений. Хотя в сегодняшней обработке не используется ни один из примеров из той статьи, тем не менее весь расчет времени сотрудников основан на работе с таблицей значений.

Содержание

Внешний вид обработки распределения времени сотрудников следующий:

Форма обработки 1С8 распределения времени сотрудников


Описание работы обработки распределения времени сотрудников

Часто на определенное задание или проект выделяется время и вам нужно быстро распределить его между исполнителями, выделив каждому равное количество. Данная обработка помогает это сделать буквально за один клик. Но для начала необходимо заполнить некоторые поля и таблицу значений.

  1. Заполните строки таблицы значений в колонке «Исполнитель». Для добавления строк можно воспользоваться кнопкой «Добавить (Ins)» в панели задач обработки (зеленая кнопка с белым плюсом).
  2. Введите общее количество времени (минуты), которое будет затрачено на проект, в поле «Общее время».
  3. Нажмите кнопку «Распределить» для распределения, указанного количества времени.
  4. Также можно изменить количество времени в поле «Время каждому», чтобы в первым в списке исполнителям было распределено именно это время, а остаток последнему. Это удобно, если вам нужно перераспределить время именно таким образом.

Поля, которые вы заполнили, будут сохранены для следующего сеанса работы. Когда вы откроете обработку снова, то увидите, что значения полей были сохранены.


Описание программного кода распределения времени на встроенном языке 1С

Читать/смотреть далее

Пример обработки 1С с сохранением настроек табличного поля

Форма обработки 1С8 с примером сохранения настроек табличного поля

Здравствуйте, уважаемые посетители! На этом блоге уже не раз было написано о
работе с табличным полем в 1С8. В двух статьях «Как отобразить флажок в строках табличного поля в системе 1С8?»
было рассказано о
первом и втором способах отображения флажка в табличном поле. В конце статьи вы можете найти дополнительные ссылки на ресурсы этого сайта, которые помогают еще больше разобраться с темой табличного поля. Если вам интересно, вы можете посмотреть, как реализовано сохранение настройки списка значений с пометками в системе 1С:Предприятие 7.7.

А сегодня я хочу поделиться небольшой обработкой, которая нагдядно демонстрирует сохранение настроек табличного поля с типом значения «ТаблицаЗначений» в системе 1С:Предприятие 8.2.

Содержание

Внешний вид обработки обработки сохранения настроек табличного поля следующий:

Форма обработки 1С8 с примером сохранения настроек табличного поля


Небольшое описание работы обработки сохранения настроек табличного поля

Читать/смотреть далее

Обработка для переноса оборотов счета для конфигурации 1С:Бухгалтерия 8

Форма внешней обработки 1С 8 по переносу оборотов одного счёта на другой

Доброго времени суток, уважаемые читатели нашего блога! Я хочу поделиться небольшой обработкой для конфигурации 1С:Бухгалтерия 8,
для переноса оборотов одного счёта на другой. При совпадении аналитики счета, будет перенесена и она, то есть,
если счет источник имеет вид субконто «Счет затрат», то значение этого субконто обязательно будет перенесено, несмотря на
то каким по счёту оно является в счёте приёмнике.

Если вы хотите скачать другие обработки для 1С 8, то можете посмотреть их
здесь, а
отчёты для 1С 8 тут.
С помощью одной из обработок вы сможете

удалить задублированные элементы в справочнике «Контрагенты»
.
Другая обработка поможет сразу

вывести на печать документы «Акт об оказании услуг», «Счет-Фактура» и «Приходный кассовый ордер»
.

Содержание

Внешний вид обработки 1С для переноса оборотов счета следующий:

Форма внешней обработки 1С 8 по переносу оборотов одного счёта на другой


Небольшая инструкция по работе с обработкой для переноса оборотов счета

  1. Для начала в поле «Конфигурация для» укажем конфигурацию, в которой мы будем работать. Значение «России» указывает, что
    работать будем в российской конфигурации «Бухгалтерия предприятия». Значение «Казахстана» указывает, что
    работать будем в конфигурации «Бухгалтерия для Казахстана».
  2. Выберем в поле «Организацию», по которой хотим переносить обороты «Счета источника».
  3. Определим период, в который хотим переносить обороты нашего счёта.
  4. Укажем счёт источник и счёт приёмник.
  5. Если выберем конкретную операцию в поле «Операция бух», то при нажатии на кнопку выполнить, все старые обороты будут удалены.
    Если поле «Операция бух» оставить пустым, то будет создана новая операция, введённая вручную.


Пример исходного кода обработки для переноса оборотов счета

Читать/смотреть далее

Внешняя обработка 1С для поиска дублей в справочнике контрагенты и удаления ссылок из документов.

Обработка 1С для конфигурации 1С:Бухгалтерия 8.2 «Поиск дублей и удаление ссылок справочника контрагенты»

Здравствуйте, уважаемые читатели блога SoftMaker.kz. Сегодня я хочу выложить небольшую обработку 1С для
работы в конфигурации 1С:Бухгалтерия, которая поможет Вам (я очень на это надеюсь)
удалить дубли элементов справочника Контрагенты и удалить ссылки в документах.

На этом ресурсе уже имеется небольшой набор
обработок и
отчетов.
Например,

здесь
обработка для быстрой печати документов «Акт об оказании услуг», «Счет-Фактура» и «Приходный кассовый ордер».
А тут обработка для переноса оборотов с одного счета на другой с помощью операции, введённой вручную.

Внешний вид обработки 1С для поиска дублей в справочнике контрагенты и удаления ссылок из документов следующий:

Обработка 1С для конфигурации 1С:Бухгалтерия 8.2 «Поиск дублей и удаление ссылок справочника контрагенты»

Инструкция по работе с обработкой 1С по поиску дублей и удалению ссылок справочника контрагенты

Читать/смотреть далее

Обработка для удаления элементов справочника в системе 1С:Предприятие 7.7

Обработка «Удаление элементов справочника»

Иногда возникает задача удалить созданные системой элементы справочников.
Например, когда элементы создаются при тестировании и исправлении базы с наименованиями,
включающими строку «ФС». В этом случае пользуюсь следующей обработкой:

Обработка «Удаление элементов справочника»

Ниже представлен код обработки:

Перем СпрСтр;

Процедура ОтметитьВсе()
Для к=1 по спис.РазмерСписка() Цикл
спис.Пометка(к,1);
КонецЦикла;
конецПроцедуры

//*******************************************
Процедура Заполнить()
Если спис.РазмерСписка() <> 0 Тогда
спис.УдалитьВсе();
КонецЕсли;
СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
Справ = СоздатьОбъект(«Справочник.» + СпрСтр);
Справ.ВыбратьЭлементы();
Пока Справ.ПолучитьЭлемент() = 1 Цикл
Состояние(Справ);
Если Справ.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;
Если Найти(Справ.Наименование, СокрЛП(Имя)) <> 0 Тогда
спис.ДобавитьЗначение(Справ.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
ОтметитьВсе();
КонецПроцедуры

Процедура СнятьВсеОтметки()
Для к=1 по спис.РазмерСписка() Цикл
спис.Пометка(к,0);
КонецЦикла;
конецПроцедуры

Процедура Инвертировать()
Для к=1 по спис.РазмерСписка() Цикл
отм=спис.Пометка(к);
отм=?(отм=1,0,1);
спис.Пометка(к,отм);
КонецЦикла;
конецПроцедуры

Процедура ВывестиОтмеченные()
Для к=1 по спис.РазмерСписка() Цикл
отм=спис.Пометка(к);
Если отм=1 Тогда
зн=спис.ПолучитьЗначение(к);
сообщить(зн);
КонецЕсли;
КонецЦикла;
конецПроцедуры

Процедура ПриОткрытии()
Для Номер = 1 по Метаданные.Справочник() Цикл
Идентификатор = Метаданные.Справочник(Номер).Идентификатор;
List.ДобавитьЗначение(Идентификатор);
КонецЦикла;
КонецПроцедуры

Процедура ОбработкаСправочников()
Перем стр;
СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
Справ = СоздатьОбъект(«Справочник.» + СпрСтр);
Для к=1 по спис.РазмерСписка() Цикл
Элемент = спис.ПолучитьЗначение(к,стр);
Если Справ.НайтиЭлемент(Элемент) = 1 Тогда
Если спис.Пометка(к) = 1 Тогда
сообщить(«Удалён элемент — « + Элемент);
Справ.Удалить(спис.Пометка(к));
КонецЕсли;
КонецЕсли;
КонецЦикла;
Заполнить();
Предупреждение(«Обработка завершена!»,3);
КонецПроцедуры

Процедура ПриСменеНазванияСправочника()
СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
Заполнить();
КонецПроцедуры

Краткая инструкция по работе с обработкой

  1. В режиме 1С:Предприятие выбрать пункт меню Файл — Открыть и выбрать обработку УдалитьЭлементыФС.ert.
  2. Выбрать из выпадающего списка «Вид справочника:» нужный Вам справочник.
  3. Чтобы найти нужные элементы справочника по наименованию введите строку
    поиска в поле «Строка поиска по справочнику:». Поиск чувствителен к регистру,
    если в наименовании встречается строка «ФС», то поиск будет успешен,
    если ввести буквы «ФС» в верхнем регистре, а не в нижнем «фс».
  4. После нажатия кнопки «Заполнить» в списке слева будут выведены
    найденные элементы справочника, если убрать отметку напротив элемента, то он не будет удалён.
  5. Нажмите кнопку «Удалить отмеченные» и будут удалены все выбранные элементы справочника.

Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!

Обработка «Печать документов» для быстрой и удобной печати документов

Внешний вид обработки «Печать документов»

Приветствую вас, уважаемые читатели блога SoftMaker.kz. Сегодня я хочу выложить небольшую обработку 1С для
работы в конфигурации 1С:Бухгалтерия, которая поможет Вам
быстро напечатать документы «Акт об оказании услуг», «Счет-Фактура» и «Приходный кассовый ордер».

Если у вас есть желание, то вы можете скачать и посмотреть небольшой набор
обработок и
отчетов, который уже имеется
на этом сайте.
Среди них обработки для версии 1С:Предприятие 8, такие как,

обработка для удаления повторяющихся элементов в справочнике «Контрагенты»
.
И обработка для переноса оборотов с одного счета на другой с помощью операции, введённой вручную, скачайте
тут.

Внешний вид обработки следующий:

Внешний вид обработки «Печать документов»

Читать/смотреть далее

Пример программного переноса элементов справочника из одной группы в другую в системе 1С:Предприятие 7.7

Изображение 1С

Доброго времени суток, уважаемые посетители! На этом блоге мы уже выкладывали обработку, которая наглядно показывала, как удалить элементы справочника, в наименовании которых встречается введенная пользователем строка или как вставить рисунок с прозрачным фоном в таблицу. Сегодня мы рассмотрим, как программно перенести элементы справочника из одной группы в другую в системе 1C:Предприятие 7.7. Итак, приступим.

Воспользуемся следующим решением:

Процедура Перенести()
СпрИмя = СокрЛП(ComboBox.ПолучитьЗначение(ComboBox.ТекущаяСтрока()));
Список = СоздатьОбъект(«СписокЗначений»);
Спр = СоздатьОбъект(«Справочник.» + СпрИмя);
Кол = 0;
Спр.ИспользоватьРодителя(Группа1);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Кол = Кол + 1;
Список.ДобавитьЗначение(Спр.ТекущийЭлемент());
Состояние(Спр.Код + » — « + Кол);
КонецЦикла;
Спр1 = СоздатьОбъект(«Справочникю.» + СпрИмя);
Для к=1 По Список.РазмерСписка() Цикл
ТекЭл = Список.ПолучитьЗначение(к);
Если Спр1.НайтиЭлемент(ТекЭл) = 1 Тогда
Спр1.Родитель = Группа2;
Спр1.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!