Конфигурация 1c Торговля – Изменение цен номенклатуры

Доброго времени суток, уважаемые посетители! На этом блоге мы уже выкладывали обработку, которая наглядно показывала, как удалить элементы справочника, в наименовании которых встречается введенная пользователем строка. Сегодня мы рассмотрим, как измененить цены в справочнике номенклатура в конфигурации 1C:Торговля версии системы 1C:Предприятие 7.7. Итак, приступим.

Для начала рассмотрим процедуру «Сформировать» обработки «Изменение цен номенклатуры», её
код здесь:

Процедура Сформировать()
НеВыбран = 0; СтрокаНеВыбран = "";
//Сначала нужно проверить заполнены ли необходимые реквизиты формы:
Если ВалютаЦены.Выбран() = 0 Тогда
НеВыбран = 1;
СтрокаНеВыбран = "Валюта цены";
Активизировать("ВалютаЦены");
КонецЕсли;
Если ЕдИзмЦены.Выбран() = 0 Тогда
НеВыбран = 1;
СтрокаНеВыбран = СтрокаНеВыбран + " Единица измерения цены";
Активизировать("ЕдИзмЦены");
КонецЕсли;
Если Дата(0) = ДатаЦены Тогда
НеВыбран = 1;
СтрокаНеВыбран = СтрокаНеВыбран + " Дата цены";
Активизировать("ДатаЦены");
КонецЕсли;
Если НеВыбран = 1 Тогда
Сообщить("Не выбрана " + СтрокаНеВыбран + " !", "!");
Возврат;
КонецЕсли;
Если ЦенаТовара = 0 Тогда
Если Вопрос("Цена товара равна нулю. Продолжить?", "Да+Нет") = "Нет" Тогда
Возврат;
КонецЕсли;
КонецЕсли;
// Проверяю у скольки элементов нужно поменять цену...
СпрТов = СоздатьОбъект("Справочник.Номенклатура");
Если Товар.Выбран() = 1 Тогда
// У группы?
Если Товар.ЭтоГруппа() = 1 Тогда
СпрТов.ИспользоватьРодителя(Товар);
Иначе
// У одного элемента?
СпрТов.НайтиЭлемент(Товар);
ИзменитьЭлемент(СпрТов.ТекущийЭлемент());
Возврат;
КонецЕсли;
КонецЕсли;
// У всех элементов справочника номенклатура, если Товар.ЭтоГруппа() = 0
СпрТов.ВыбратьЭлементы();
Пока СпрТов.ПолучитьЭлемент() = 1 Цикл
Если СпрТов.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;
Если ИзменитьЭлемент(СпрТов.ТекущийЭлемент()) = 0 Тогда
Возврат;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Читать/смотреть далее