Обработка 1С для загрузки штрихкодов из Excel для УТП

Форма обработки 1С8 загрузка штрихкодов из Excel для УТП

Здравствуйте, уважаемые читатели блога SoftMaker.kz! В прошлый раз здесь была опубликована для загрузки обработка распределения времени, которая помогает тем, кто хочет быстро распределить время сотрудников. Сегодня будет размещена обработка, которая поможет быстро загрузить штрихкоды в информационную базу конфигурации Управление Торговым Предприятием.

Содержание

Внешний вид обработки загрузка штрихкодов из Excel для УТП следующий:


Форма обработки 1С8 загрузка штрихкодов из Excel для УТП

Описание работы обработки загрузка штрихкодов из Excel для УТП

Работа с этой обработкой не составляет большого труда.

  1. Нажмите кнопку «Выполнить» для выбора файла.
  2. С помощью диалога выбора фала найдите нужный вам файл Excel.
  3. Чтобы удалить ненужные штрихкоды, введите часть штрихкода в поле поиска штрихкодов и нажмите кнопку «Найти».
  4. После заполнения таблицы нажмите кнопку «Удалить».

Загрузка штрихкодов для удаления из регистра сведений

Описание программного кода загрузки штрихкодов из Excel на встроенном языке 1С

Когда вы нажимаете кнопку «Выполнить» срабатывает процедура «КнопкаВыполнитьНажатие» и после выбора файла происходит загрузка штрихкодов из вашего файла Excel.


Процедура КнопкаВыполнитьНажатие(Кнопка)
Режим = РежимДиалогаВыбораФайла.Открытие;
ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
Фильтр = “Файл Эксель 2007 (*.xlsx)|*.xlsx|Файл Эксель (*.xls)|*.xls”;
ДиалогОткрытияФайла.Фильтр = Фильтр;
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
ДиалогОткрытияФайла.Заголовок = “Выберите файл загрузки”;
Если ДиалогОткрытияФайла.Выбрать() Тогда
ТаблицаШтрихкодов.Колонки.Очистить();
ТаблицаШтрихкодов.Колонки.Добавить(“Артикул”,
Новый ОписаниеТипов(“Строка”), , 25);
ТаблицаШтрихкодов.Колонки.Добавить(“ШтрихКод”,
Новый ОписаниеТипов(“Строка”), , 200);

ПутьЗагрузки = ДиалогОткрытияФайла.ПолноеИмяФайла;
// Получение объекта COM, соответствующего файлу
Эксель = ПолучитьCOMОбъект(ПутьЗагрузки);
Книга = Эксель.Application.Workbooks.Open(ПутьЗагрузки);

Товары = Справочники.Номенклатура;

Лист = Книга.Worksheets(1);
Конец = Ложь;
Счетчик = 1;
Пока НЕ Конец Цикл
Артикул = Лист.Cells(Счетчик,1).Value;
ШтрихКод = Лист.Cells(Счетчик,2).Value;
Конец = (ШтрихКод = Неопределено) И (Артикул = Неопределено);
Если НЕ Конец Тогда
НоваяСтрока = ТаблицаШтрихкодов.Добавить();
НоваяСтрока.Артикул = Артикул;
НоваяСтрока.ШтрихКод = XMLСтрока(ШтрихКод);
Счетчик = Счетчик + 1;
Состояние(“Артикул: ““” + Артикул +
“”” и штрихкод: ““” + Штрихкод + “”“”);
КонецЕсли;
КонецЦикла;

Книга.Close();
Эксель = Неопределено;

ЭлементыФормы.ТаблицаШтрихкодов.Значение = ТаблицаШтрихкодов;
ЭлементыФормы.ТаблицаШтрихкодов.СоздатьКолонки();
ЗаписатьШК(ТаблицаШтрихкодов);
Сообщение = Новый СообщениеПользователю();
Сообщение.Текст = “Загрузка завершена!”;
Сообщение.Сообщить();
КонецЕсли;
КонецПроцедуры

Описание файла Excel для загрузки штрихкодов

Ваш файл Excel, должен состоять из двух колонок:

  1. Первая колонка должна содержать артикул товара.
  2. Вторая колонка должна содержать штрихкод товара.

Конечно, здесь опубликован не весь программный код обработки загрузки штрихкодов. Но его можно увидеть, да и опробовать саму эту обработку, если скачать по ссылке ниже.


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!

0 ответы

Ответить

Want to join the discussion?
Feel free to contribute!

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *