Обработка для копирования файлов и папок из 1С 8

Форма обработки 1С8 копирования файлов и папок

Доброго времени суток, уважаемые читатели нашего блога! Я хочу поделиться небольшой обработкой,
для копирования файлов и папок из 1С, с указанием некоторого условия. Мне она пригодилась для переноса файлов и папок из папки Dropbox, в которой среди важных для меня файлов, скопилось много ненужных мне файлов с расширением «dropbox.attributes». Задача стояла перенести только мои файлы без этого хлама, сохранив при этом иерархию папок.

Также вы можете скачать другие обработки для 1С 8, перейдя по ссылкам
здесь, а
отчёты для 1С 8 тут.
С помощью одной из обработок вы сможете

удалить задублированные элементы в справочнике «Контрагенты»
.
Другая обработка поможет тем, кто работает в конфигурации УТП, она предназначена для

загрузки штрихкодов из Excel
.

Содержание

Внешний вид обработки копирования файлов и папок из 1С:


Форма обработки 1С8 копирования файлов и папок

Описание работы обработки копирования файлов и папок

Работа с этой обработкой не составляет большого труда.

  1. Выберите папку откуда вы хотите скопировать файлы и папки из поля «Путь загрузки:», нажав на кнопку «…» для выбора папки.
  2. С помощью диалога выбора каталога найдите нужный вам каталог.
  3. Выберите папку куда вы хотите скопировать файлы и папки из поля «Путь выгрузки:», нажав на кнопку «…» для выбора папки.
  4. С помощью диалога выбора каталога найдите нужный вам каталог.
  5. Если вы хотите, скопировать не все файлы, а только те, в которых встречается определенный набор символов, тогда укажите в
    в выпадающем списке «Вид сравнения» и условие сравнения в поле рядом.
  6. Если в выпадающем списке «Вид сравнения» вы выбрали значение «Не содержит», то будут скопированы все файлы, у которых в названии нет набора символов, который указан в поле рядом с выпадающим списком. (На изображении показано, что будут скопированы файлы, у которых нет в названии «dropbox.attributes»).
  7. Если в выпадающем списке «Вид сравнения» вы выбрали значение «Содержит», то будут скопированы все файлы, у которых в названии есть набор символов, который указан в поле рядом с выпадающим списком.
  8. Поиск по набору символов чуствителен к регистру строки, который вы вводите в условие поиска файлов и папок. Например, если вы выбрали в выпадающем списке «Вид сравнения» значение «Содержит» и введете значение «1с», то будут скопированы файлы, у которых в названии есть «1с», но не скопируются файлы со словом «1С».
  9. Нажать на кнопку «Выполнить». Появятся сообщения о скопированных файлах и папках.


Создан каталог: Z:\Проба\7.7\ert
Скопирован файл: Z:\Проба\7.7\ert\ИзменитьСтоимостьПостТМЗИмпорт.ert
Скопирован файл: Z:\Проба\7.7\KzAccn273.rar
Создан каталог: Z:\Проба\7.7\RegRep
Скопирован файл: Z:\Проба\7.7\RegRep\ACC_Kz_20120202.zip
Скопирован файл: Z:\Проба\7.7\RegRep\ExtForms270.7z
Скопирован файл: Z:\Проба\7.7\RegRep\kz_accnr_12q2001.2048k.rar
Скопирован файл: Z:\Проба\8\RegOtchetnost.zip
Загрузка завершена!

Описание программного кода обработки копирования файлов и папок из 1С

Когда вы нажимаете кнопку «Выполнить» срабатывает процедура «КнопкаВыполнитьНажатие».

Процедура КнопкаВыполнитьНажатие(Кнопка)
Сообщение = Новый СообщениеПользователю();
СписокФайлов = НайтиФайлы(ПутьЗагрузки, “*.*”, Истина);
Для каждого ФайлСписка Из СписокФайлов Цикл
// Не буду копировать скрытые файлы mac os
Если Лев(ФайлСписка.Имя, 2) = “._” Тогда
Продолжить;
КонецЕсли;
Если Условие(ФайлСписка.Имя) Тогда
Продолжить;
КонецЕсли;
ФайлНазначения = СтрЗаменить(ФайлСписка.ПолноеИмя, ПутьЗагрузки, ПутьВыгрузки);
Если ФайлСписка.ЭтоКаталог() Тогда
Если ФайлСписка.Существует() Тогда
Попытка
СоздатьКаталог(ФайлНазначения);
Сообщение.Текст = “Создан каталог: “ + ФайлНазначения;
Сообщение.Сообщить();
Исключение
Сообщение.Текст = “Не удалось создать каталог: “ + ОписаниеОшибки();
Сообщение.Сообщить();
КонецПопытки;
КонецЕсли;
Продолжить;
КонецЕсли;
Если ФайлСписка.Существует() Тогда
Попытка
КопироватьФайл(ФайлСписка.ПолноеИмя, ФайлНазначения);
Сообщение.Текст = “Скопирован файл: “ + ФайлНазначения;
Сообщение.Сообщить();
Исключение
Сообщение.Текст = “Не удалось скопировать файл! Ошибка: “ + ОписаниеОшибки();
Сообщение.Сообщить();
КонецПопытки;
КонецЕсли;
КонецЦикла;
Сообщение.Текст = “Загрузка завершена!”;
Сообщение.Сообщить();
КонецПроцедуры

Конечно, здесь опубликован не весь программный код обработки загрузки штрихкодов. Но его можно увидеть, да и опробовать саму эту обработку, если скачать по ссылке ниже. Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!

0 ответы

Ответить

Want to join the discussion?
Feel free to contribute!

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *