Обработка для удаления элементов справочника в системе 1С:Предприятие 7.7

Обработка «Удаление элементов справочника»

Иногда возникает задача удалить созданные системой элементы справочников.
Например, когда элементы создаются при тестировании и исправлении базы с наименованиями,
включающими строку “ФС”. В этом случае пользуюсь следующей обработкой:

Обработка «Удаление элементов справочника»

Ниже представлен код обработки:

Перем СпрСтр;

Процедура ОтметитьВсе()
Для к=1 по спис.РазмерСписка() Цикл
спис.Пометка(к,1);
КонецЦикла;
конецПроцедуры

//*******************************************
Процедура Заполнить()
Если спис.РазмерСписка() <> 0 Тогда
спис.УдалитьВсе();
КонецЕсли;
СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
Справ = СоздатьОбъект(“Справочник.” + СпрСтр);
Справ.ВыбратьЭлементы();
Пока Справ.ПолучитьЭлемент() = 1 Цикл
Состояние(Справ);
Если Справ.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;
Если Найти(Справ.Наименование, СокрЛП(Имя)) <> 0 Тогда
спис.ДобавитьЗначение(Справ.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
ОтметитьВсе();
КонецПроцедуры

Процедура СнятьВсеОтметки()
Для к=1 по спис.РазмерСписка() Цикл
спис.Пометка(к,0);
КонецЦикла;
конецПроцедуры

Процедура Инвертировать()
Для к=1 по спис.РазмерСписка() Цикл
отм=спис.Пометка(к);
отм=?(отм=1,0,1);
спис.Пометка(к,отм);
КонецЦикла;
конецПроцедуры

Процедура ВывестиОтмеченные()
Для к=1 по спис.РазмерСписка() Цикл
отм=спис.Пометка(к);
Если отм=1 Тогда
зн=спис.ПолучитьЗначение(к);
сообщить(зн);
КонецЕсли;
КонецЦикла;
конецПроцедуры

Процедура ПриОткрытии()
Для Номер = 1 по Метаданные.Справочник() Цикл
Идентификатор = Метаданные.Справочник(Номер).Идентификатор;
List.ДобавитьЗначение(Идентификатор);
КонецЦикла;
КонецПроцедуры

Процедура ОбработкаСправочников()
Перем стр;
СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
Справ = СоздатьОбъект(“Справочник.” + СпрСтр);
Для к=1 по спис.РазмерСписка() Цикл
Элемент = спис.ПолучитьЗначение(к,стр);
Если Справ.НайтиЭлемент(Элемент) = 1 Тогда
Если спис.Пометка(к) = 1 Тогда
сообщить(“Удалён элемент – “ + Элемент);
Справ.Удалить(спис.Пометка(к));
КонецЕсли;
КонецЕсли;
КонецЦикла;
Заполнить();
Предупреждение(“Обработка завершена!”,3);
КонецПроцедуры

Процедура ПриСменеНазванияСправочника()
СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
Заполнить();
КонецПроцедуры

Краткая инструкция по работе с обработкой

  1. В режиме 1С:Предприятие выбрать пункт меню Файл – Открыть и выбрать обработку УдалитьЭлементыФС.ert.
  2. Выбрать из выпадающего списка «Вид справочника:» нужный Вам справочник.
  3. Чтобы найти нужные элементы справочника по наименованию введите строку
    поиска в поле «Строка поиска по справочнику:». Поиск чувствителен к регистру,
    если в наименовании встречается строка “ФС”, то поиск будет успешен,
    если ввести буквы “ФС” в верхнем регистре, а не в нижнем “фс”.
  4. После нажатия кнопки «Заполнить» в списке слева будут выведены
    найденные элементы справочника, если убрать отметку напротив элемента, то он не будет удалён.
  5. Нажмите кнопку «Удалить отмеченные» и будут удалены все выбранные элементы справочника.

Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!

0 ответы

Ответить

Want to join the discussion?
Feel free to contribute!

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *