Обработка для установки главного узла базы 1С 8

Форма обработки 1С8 установки главного узла распределенной информационной базы

Доброго времени суток, уважаемые читатели нашего блога! Выкладываю небольшую обработку,
установки главного узла базы 1С 8. Обычно, функционал этой обработки помогает, когда необходимо, что бы ваша база из периферийной стала центральной или наоборот, вам нужно подчинить или назначить вашей базе главный узел распределенной информационной базы (РИБ). Практическое применение этой обработки для исправления ошибок обмена здесь.

В прошлый раз была выложена неплохая обработка для копирования файлов и папок напрямую из 1С 8, а также обработка для
загрузки штрихкодов из Excel
.

Содержание

Внешний вид обработки для назначения главного узла базы:

Форма обработки 1С8 установки главного узла распределенной информационной базы

Описание работы обработки установки главного узла базы

Работа с этой обработкой не составляет большого труда.

  • Скачайте обработку по ссылке в конце статьи.
  • Затем откройте её

    в режиме 1С:Предприятие 8
    .
  • Перейдите к пункту меню «Файл» | «Открыть…» (Ctrl+O).
  • После открытия, на форме обработки появится надпись, указывающая является ли текущая база узлом распределенной информационной базы. Если текущая информационная база является узлом распределенной информационной базы, то вы увидите следующую надпись:

    «Главный узел: Название вашего узла»
  • Если текущая информационная база не является узлом распределенной информационной базы или главный узел для нее не определен (она сама является корневым узлом), то вы увидите другую надпись:

    «Главный узел неопределён.
    Текущая информационная база не является узлом распределенной
    информационной базы или она сама является корневым узлом.»
  • Если вам нужно установить или изменить главный узел РИБ, то выберите план обмена, который вы хотите установить главным узлом. Важно, чтобы план обмена, который вы выберите, был планом обмена распределенной информационной базы. Затем нажмите кнопку «Установить главный узел».
  • Если вы выберите предопределенный узел (в списке планов обмена его пиктограмма выделена зеленым шариком справа), соответствующий данной базе данных, то у вам будет выдано такое предупреждение:

    <<Название вашего узла>> является текущим узлом информационной базы!
  • Если вы выберите узел, который уже является главным для текущей базы (в списке планов обмена его пиктограмма желтым цветом), то у вам будет выдано другое предупреждение:

    <<Название вашего узла>> уже является главным узлом текущей БД!
  • Если у вас уже установлен главный узел РИБ и вы хотите отменить назначение главного узла, тогда нажмите кнопку «Отменить назначение главного узла». Эта кнопка будет доступна, если для текущей информационной базы главный узел определен.
  • Хотелось бы отметить, что у вас получится изменить главный узел, если вы будете работать в монопольном режиме 1С, то есть только ваш сеанс должен быть подключен к текущей базе данных. Если кто-то еще работает в ней, то вы получите примерно такое сообщение:

    «Ошибка исключительной блокировки информационной базы.
    Активные сеансы:…»

Часть программного кода обработки на встроенном языке 1С

Когда вы нажимаете кнопку «Установить главный узел» срабатывает процедура «ОсновныеДействияФормыУстановитьГлавныйУзел».

Процедура ОсновныеДействияФормыУстановитьГлавныйУзел(Кнопка)
Если ГлавныйУзел <> Undefined
И ГлавныйУзел = ПланыОбмена.ГлавныйУзел() Тогда
Предупреждение(“<<“ + ГлавныйУзел.Наименование +
“>> уже является главным узлом текущей БД!”,
3, “Выберите другой узел БД!”);
Возврат;
КонецЕсли;
Если ГлавныйУзел = Undefined ИЛИ ГлавныйУзел.Пустая() Тогда
Предупреждение(“Сначала выберите узел!”, 3, “Выберите узел БД!”);
Иначе
ЭтотУзел = ПланыОбмена[ГлавныйУзел.Метаданные().Имя].ЭтотУзел();
Если ЭтотУзел = ГлавныйУзел Тогда
Предупреждение(“<<“ + ГлавныйУзел.Наименование +
“>> является текущим узлом информационной базы!”,
3, “Выберите другой узел БД!”);
Иначе
ПланыОбмена.УстановитьГлавныйУзел(ГлавныйУзел);
УстановитьНадписьУзла();
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Конечно, здесь опубликован не весь программный код обработки для установки главного узла ИБ. Но его можно увидеть, да и опробовать саму эту обработку, если скачать по ссылке ниже. Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!

0 ответы

Ответить

Want to join the discussion?
Feel free to contribute!

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *