Записи

Отправка почты из 1С 8

Страница помощи при возникновении ошибок с отправкой почты gmail

Доброго времени суток, коллеги! Сегодня пытался настроить отправку сообщений из 1С и столкнулся с проблемой отправки сообщений. Как оказалось все упиралось в настройки gmail. Ну давайте все по порядку. Читать/смотреть далее

Вывод изображения товара в отчете «Печать прайс-листа»

Прайс-лист с выводом картинок в печатную форму отчета

Доброго времени суток, уважаемые читатели блога SoftMaker.kz. Сегодня я выкладываю внешний отчет 1С «Печать прайс-листа» для конфигурации Управление торговлей для Казахстана, редакция 2.2 с возможностью вывода картинок номенклатуры в печатную форму.

Прошлый отчёт был предназначен для конфигурации 1C 8 Бухгалтерия для Казахстана, редакция 2.0 и для российской конфигурации Бухгалтерия предприятия, редакция 2.0., который используется для анализ движения номенклатуры по месяцам. Вы можете скачать еще один отчет об анализе дебиторской задолженности, только для конфигурации Управление торговым предприятием (УТП). Читать/смотреть далее

Примеры работы с табличным полем в 1С 8

Примеры настройки табличного поля в 1С:Предприятие 8


Примеры настройки табличного поля в 1С:Предприятие 8

Содержание

  1. Как отобразить данные в элементе управления ТабличноеПоле?
  2. Как при разворачивании формы на весь экран сделать, чтобы табличное поле изменяло свой размер?
  3. Как программно установить видимость колонки табличного поля?
  4. Как программно активизировать строку табличного поля с типом значения РегистрСведенийСписок?
  5. Как создать контекстное меню для табличного поля?
  6. Как в табличном поле с типом значения справочник, отображать только группы?
  7. Как изменить значение ячейки табличного поля?
  8. Как сделать текущим значение колонки табличного поля и присвоить этой колонке тип?
  9. Как в табличном поле установить флажок элементом управления для колонки?
  10. Как программно создать колонку табличного поля с элементом управления «Флажок»?
  11. Как реализовать событие двойного клика по строке табличного поля?
  12. Как узнать существует ли колонка табличного поля?
  13. Как из табличного поля получить значение ячейки, если известно имя колонки?

Как отобразить данные в элементе управления ТабличноеПоле?

ЭлементыФормы.ТабличноеПоле.Значение=ТаблицаЗначений1; 
ЭлементыФормы.ТабличноеПоле.СоздатьКолонки();

Примеры реализации данного метода вы можете посмотреть здесь и тут.

Как при разворачивании формы на весь экран сделать, чтобы табличное поле изменяло свой размер?

Читать/смотреть далее

Пример обработки 1С с сохранением настроек табличного поля

Форма обработки 1С8 с примером сохранения настроек табличного поля

Здравствуйте, уважаемые посетители! На этом блоге уже не раз было написано о
работе с табличным полем в 1С8. В двух статьях «Как отобразить флажок в строках табличного поля в системе 1С8?»
было рассказано о
первом и втором способах отображения флажка в табличном поле. В конце статьи вы можете найти дополнительные ссылки на ресурсы этого сайта, которые помогают еще больше разобраться с темой табличного поля. Если вам интересно, вы можете посмотреть, как реализовано сохранение настройки списка значений с пометками в системе 1С:Предприятие 7.7.

А сегодня я хочу поделиться небольшой обработкой, которая нагдядно демонстрирует сохранение настроек табличного поля с типом значения «ТаблицаЗначений» в системе 1С:Предприятие 8.2.

Содержание

Внешний вид обработки обработки сохранения настроек табличного поля следующий:

Форма обработки 1С8 с примером сохранения настроек табличного поля


Небольшое описание работы обработки сохранения настроек табличного поля

Читать/смотреть далее

Пример использования функций СКД Массив (Array) и СоединитьСтроки (JoinStrings) в отчёте 1С 8

Форма отчета 1С 8 после применения функций СКД Массив (Array) и СоединитьСтроки (JoinStrings)

Доброго времени суток, уважаемые читатели нашего блога! Сегодня я хочу рассказать, на реальном примере, как
использовать функции СКД Массив (Array) и СоединитьСтроки (JoinStrings). В статье об
СКД
немного упоминалось, как работать с
функциями языка выражений СКД на закладке
«Вычисляемые поля», также уже объяснялось как
настроить итоги в схеме компоновки данных 1С, используя закладку «Ресурсы». Сегодня мы ещё раз обратим внимание на эти
закладки в свете нашей темы.

Содержание

Внешний вид примера отчета 1С с использованием двух функций СКД Массив и СоединитьСтроки следующий:

Форма отчета 1С 8 после применения функций СКД Массив (Array) и СоединитьСтроки (JoinStrings)


Постановка задачи для применения функций СКД Массив (Array) и СоединитьСтроки (JoinStrings)

Читать/смотреть далее

Примеры программирования с таблицей значений в системе 1С:Предприятие 8

Таблица значений в 1C8

Доброго времени суток, уважаемые читатели! На этом сайте уже были описаны примеры работы с таблицей значений. Например, было написано как объединить две таблицы значений. Сегодня я поделюсь ещё некоторыми примерами программирования с таблицей значений в системе 1С:Предприятие 8.


Таблица значений в 1C8

Отбор по типу значения в таблице значений

Читать/смотреть далее

Примеры программирования в 1С 8

Примеры программирования в 1С 8


Примеры программирования в 1С 8

  1. Как правильно реализовать цикл с постусловием?
  2. Как реализовать цикл с уменьшающимся счетчиком?
  3. Как получить название документа (аналог метода 1С 7.7 Вид())?
  4. Как узнать имеет ли текущий пользователь определённую роль?
  5. Как программно формируются кнопки печати документов в 1С:Предприятие 8.2?
  6. Как сделать запись в журнал регистрации 1С:Предприятие 8?
  7. Как правильно сделать выбор из составного типа данных?
  8. Как узнать тип объекта 1С8?
  9. Как открыть выпадающий список около элемента управления формы?
  10. Как программно переключить страницу (закладку) на «Панели»?
  11. Как активизировать элемент формы?
  12. Как обратиться к текущей странице формы, если на форму не помещён элемент управления формы «Панель»?
  13. Как установить значение в поле ввода в табличной части документа?
  14. Как правильно удалить строки из текстового файла с помощью встроенного языка системы 1С8?
  15. Как в 1С8 получить из строки с разделителями определённую подстроку по её позиции?
  16. Как проверить существует ли реквизит справочника 1с8?
  17. Как перебрать субконто счёта?
  18. Как устранить ошибку: Тип не является подмножеством типа значений плана видов характеристик?

Читать/смотреть далее

Пример программного переноса элементов справочника из одной группы в другую в системе 1С:Предприятие 7.7

Изображение 1С

Доброго времени суток, уважаемые посетители! На этом блоге мы уже выкладывали обработку, которая наглядно показывала, как удалить элементы справочника, в наименовании которых встречается введенная пользователем строка или как вставить рисунок с прозрачным фоном в таблицу. Сегодня мы рассмотрим, как программно перенести элементы справочника из одной группы в другую в системе 1C:Предприятие 7.7. Итак, приступим.

Воспользуемся следующим решением:

Процедура Перенести()
СпрИмя = СокрЛП(ComboBox.ПолучитьЗначение(ComboBox.ТекущаяСтрока()));
Список = СоздатьОбъект(«СписокЗначений»);
Спр = СоздатьОбъект(«Справочник.» + СпрИмя);
Кол = 0;
Спр.ИспользоватьРодителя(Группа1);
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Кол = Кол + 1;
Список.ДобавитьЗначение(Спр.ТекущийЭлемент());
Состояние(Спр.Код + » — « + Кол);
КонецЦикла;
Спр1 = СоздатьОбъект(«Справочникю.» + СпрИмя);
Для к=1 По Список.РазмерСписка() Цикл
ТекЭл = Список.ПолучитьЗначение(к);
Если Спр1.НайтиЭлемент(ТекЭл) = 1 Тогда
Спр1.Родитель = Группа2;
Спр1.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


  Пожалуйста, Войдите или Зарегистрируйтесь чтобы получить ссылку на скачивание.


Этот блог читают уже более 3000 человек
- читай и ТЫ!

Пример объединения запроса в отчете по резервам в системе 1С:Предприятие 8

Форма отчета 1С8 отчета по резервам

Здравствуйте, уважаемые читатели блога SoftMaker.kz! В статье «Для чего используется объединение результатов запросов в системе 1С:Предприятие 8?» было подробно рассказано об объединении запросов. Здесь приведён реальный пример реализации объединения для типовой конфигурации Управление торговым предприятием для Казахстана, редакция 1.0.

Внешний вид отчета по резервам следующий:

Форма отчета 1С8 отчета по резервам

Ниже приведен код запроса для формирования отчета по резервам с помощью объединения:

Читать/смотреть далее