Здравствуйте, уважаемые читатели блога SoftMaker.kz! В прошлый раз здесь была опубликована для загрузки обработка распределения времени, которая помогает тем, кто хочет быстро распределить время сотрудников. Сегодня будет размещена обработка, которая поможет быстро загрузить штрихкоды в информационную базу конфигурации Управление Торговым Предприятием.

Содержание

Внешний вид обработки загрузка штрихкодов из Excel для УТП следующий:


Форма обработки 1С8 загрузка штрихкодов из Excel для УТП

Описание работы обработки загрузка штрихкодов из Excel для УТП

Работа с этой обработкой не составляет большого труда.

  • Скачайте обработку по ссылке в конце статьи.
  • Затем откройте её в режиме 1С:Предприятие 8.
  • Перейдите к пункту меню «Файл» | «Открыть…» (Ctrl+O).
  • После открытия нужно открыть файл Excel, который приложен к загрузке обработки, затем выделить ячейки с данными которые вы хотите загрузить.
  • Нажмите кнопку «Выполнить» для загрузки данных из буфера обмена.
  • В табличном поле обработки появятся записи штрихкодов, которые были загружены в базу.

Никаких заголовков для колонок файла делать не нужно.

 

Описание программного кода загрузки штрихкодов из Excel на встроенном языке 1С

Когда вы нажимаете кнопку «Выполнить» срабатывает процедура «КнопкаВыполнитьНажатие» и после выбора файла происходит загрузка штрихкодов из буфера обмена.

 

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	МассивКол = ПрочитатьБуферОбмена(ПолучитьТекстБуфераОбмена(), Символы.Таб);

	Если ЗначениеЗаполнено(МассивКол) Тогда
		ТаблицаШтрихкодов.Колонки.Очистить();
		ТаблицаШтрихкодов.Колонки.Добавить("Артикул", Новый ОписаниеТипов("Строка"), , 25); 
		ТаблицаШтрихкодов.Колонки.Добавить("ШтрихКод", Новый ОписаниеТипов("Строка"), , 200);		
		
		Для каждого Товар из МассивКол Цикл
			Артикул = СокрЛП(Товар[0]);	
			ШтрихКод = СокрЛП(Товар[1]);
			НоваяСтрока = ТаблицаШтрихкодов.Добавить();
			НоваяСтрока.Артикул  = Артикул;
			НоваяСтрока.ШтрихКод = XMLСтрока(ШтрихКод);
			Состояние("Артикул: """ + Артикул + """ и штрихкод: """ + Штрихкод + """");
		КонецЦикла;
				 
		ЭлементыФормы.ТаблицаШтрихкодов.Значение = ТаблицаШтрихкодов;
		ЭлементыФормы.ТаблицаШтрихкодов.СоздатьКолонки();
		ЗаписатьШК(ТаблицаШтрихкодов);
		Сообщение = Новый СообщениеПользователю();
		Сообщение.Текст = "Загрузка завершена!";
		Сообщение.Сообщить();
	КонецЕсли;
КонецПроцедуры

 

Описание файла Excel для загрузки штрихкодов

Ваш файл Excel, должен состоять из двух колонок:

  1. Первая колонка должна содержать артикул товара.
  2. Вторая колонка должна содержать штрихкод товара.

Никаких заголовков для колонок файла делать не нужно. Артикулы товаров должны соответствовать артикулам в вашей базе.

Конечно, здесь опубликован не весь программный код обработки загрузки штрихкодов. Но его можно увидеть, да и опробовать саму эту обработку, если скачать по ссылке.

0 ответы

Ответить

Хотите присоединиться к обсуждению?
Не стесняйтесь вносить свой вклад!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *