Иногда возникает задача удалить созданные системой элементы справочников. Например, когда элементы создаются при тестировании и исправлении базы с наименованиями, включающими строку «ФС». В этом случае пользуюсь обработкой, представленной на иллюстрации в начале статьи.

Ниже представлен, небольшой отрывок кода обработки:

//*******************************************
Процедура Заполнить()
	Если спис.РазмерСписка() <> 0 Тогда
		спис.УдалитьВсе();
	КонецЕсли;
	СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
	Справ = СоздатьОбъект(«Справочник.» + СпрСтр);
	Справ.ВыбратьЭлементы();
	Пока Справ.ПолучитьЭлемент() = 1 Цикл
		Состояние(Справ);
		...
	КонецЦикла;
	ОтметитьВсе();
КонецПроцедуры

...

Процедура ОбработкаСправочников()
	Перем стр;
	СпрСтр = List.ПолучитьЗначение(List.ТекущаяСтрока());
	Справ = СоздатьОбъект(«Справочник.» + СпрСтр);
	Для к=1 по спис.РазмерСписка() Цикл
		...
	КонецЦикла;
	Заполнить();
	Предупреждение(«Обработка завершена!»,3);
КонецПроцедуры

Краткая инструкция по работе с обработкой

  1. В режиме 1С:Предприятие выбрать пункт меню Файл — Открыть и выбрать обработку УдалитьЭлементыФС.ert.
  2. Выбрать из выпадающего списка «Вид справочника:» нужный Вам справочник.
  3. Чтобы найти нужные элементы справочника по наименованию введите строку
    поиска в поле «Строка поиска по справочнику:». Поиск чувствителен к регистру,
    если в наименовании встречается строка «ФС», то поиск будет успешен,
    если ввести буквы «ФС» в верхнем регистре, а не в нижнем «фс».
  4. После нажатия кнопки «Заполнить» в списке слева будут выведены
    найденные элементы справочника, если убрать отметку напротив элемента, то он не будет удалён.
  5. Нажмите кнопку «Удалить отмеченные» и будут удалены все выбранные элементы справочника.

Этот блог читают уже более 3000 человек - читай и ТЫ!
0 ответы

Ответить

Хотите присоединиться к обсуждению?
Не стесняйтесь вносить свой вклад!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *