Доброго времени суток, уважаемые коллеги! Выкладываю обработку, которая загружает исследования из Excel через буфер обмена в базу данных 1С конфигурации Госпитальная информационная система, версия 2.0.28.2 для Казахстана. Обработка позволяет загрузить данные, скопировав их из файла Excel в буфер обмена и загрузить напрямую без табличного документа. Прошлая обработка позволяет загрузить данные о платежных картах с использованием табличного документа.

Описание работы загрузки медицинских исследований

Обработка позволяет загрузить данные, скопировав их из файла Excel в буфер обмена, без использования табличного документа.

  • Скачайте обработку и шаблон файла Excel для загрузки по ссылке в конце статьи.
  • Затем откройте её в режиме 1С:Предприятие 8.
  • Перейдите к пункту меню «Файл» | «Открыть…» (Ctrl+O).
  • Выберите группу, в которую хотите загрузить элементы справочника Исследования. Если не выбрать группу, то элементы будут загружены в корень справочника.
  • После открытия нужно открыть файл Excel, который приложен к загрузке обработки, затем выделить ячейки с данными которые вы хотите загрузить.
  • Перейти в 1С и нажать на кнопку Загрузить, чтобы были созданы элементы справочника Исследования. Также будут созданы элементы в подчиненном справочнике ЭлементыИсследования на основании, полученных из буфера обмена данных.

Заполнение основных реквизитов справочников (наименование, родитель) справочника Исследования, заполняются из буфера обмена. Обработка работает, как в обычном приложении, так и в управляемом. Шаблон файла Excel состоит из двух колонок: наименование и флаг, указывающий на то, какой элемент справочника нужно создать. Если вторая колонка равна 1, то будет создан элемент справочника Исследования, иначе будет создан подчиненный элемент справочника ЭлементыИсследования.

Часть программного кода обработки на встроенном языке 1С

Когда вы нажимаете кнопку Загрузить срабатывает процедура ЗагрузитьНаСервере и выполняется следующий код:

Процедура ЗагрузитьНаСервере(ТекстИзБуфера)
	// Читаем данные буфера
	МассивКол = ПрочитатьБуферОбмена(ТекстИзБуфера, Символы.Таб);
	Если ЗначениеЗаполнено(МассивКол) Тогда      	
		Для каждого Элемент Из МассивКол Цикл		
			ЭтоИсследование = Элемент[1] = "1";	
			Если ЭтоИсследование Тогда 	
				Исследование = Справочники.Исследования.СоздатьЭлемент();
				Исследование.Наименование = Элемент[0];
				Исследование.Родитель = Группа;
				Исследование.Записать();
			Иначе
				ЭлементИсследования = Справочники.ЭлементыИсследования.СоздатьЭлемент();
				ЭлементИсследования.Наименование = Элемент[0];
				ЭлементИсследования.Владелец = Исследование.Ссылка;
				ЭлементИсследования.Записать();
			КонецЕсли;	
		КонецЦикла;	
	КонецЕсли;
	Сообщить("Загрузка завершена!");
КонецПроцедуры

Конечно, здесь опубликован не весь программный код обработки для загрузки данных об исследованиях из Excel через буфер обмена. Но его можно увидеть, да и опробовать саму эту обработку, если скачать по ссылке. Если у вас другие данные или другая конфигурация, то мы можем помочь изменить обработку под ваши нужды, обращайтесь.

0 ответы

Ответить

Хотите присоединиться к обсуждению?
Не стесняйтесь вносить свой вклад!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *