Доброго времени суток, уважаемые посетители! На этом блоге мы уже выкладывали обработку, которая наглядно показывала, как удалить элементы справочника, в наименовании которых встречается введенная пользователем строка или как вставить рисунок с прозрачным фоном в таблицу. Сегодня мы рассмотрим, как программно перенести все элементы справочника из одной группы в другую в системе 1C:Предприятие 7.7. Итак, приступим.

Описание работы обработки переноса элементов справочника в другую группу

  1. Скачайте обработку по ссылке в конце статьи.
  2. Затем откройте её в режиме 1С:Предприятие 8.
  3. Перейдите к пункту меню «Файл» | «Открыть…» (Ctrl+O).
  4. Выберите справочник из выпадающего списка.
  5. Укажите папку, из которой вы хотите перенести элементы справочника в поле «Из группы».
  6. Затем укажите папку, в которую вы хотите перенести элементы справочника в поле «В группу».
  7. Нажмите на кнопку «Перенести».

Пример исходного кода обработки для переноса элементов в другую группу

Воспользуемся следующим решением:

Процедура Перенести()
	СпрИмя = СокрЛП(ComboBox.ПолучитьЗначение(ComboBox.ТекущаяСтрока()));
	Список = СоздатьОбъект("СписокЗначений");
	Спр = СоздатьОбъект("Справочник." + СпрИмя);
	Кол = 0;
	Спр.ИспользоватьРодителя(Группа1);
	Спр.ВыбратьЭлементы();
	Пока Спр.ПолучитьЭлемент() = 1 Цикл
		Кол = Кол + 1;
		Список.ДобавитьЗначение(Спр.ТекущийЭлемент());
		Состояние(Спр.Код + " - " + Кол);
	КонецЦикла;
	Спр1 = СоздатьОбъект("Справочникю." + СпрИмя);
	Для к=1 По Список.РазмерСписка() Цикл
		ТекЭл = Список.ПолучитьЗначение(к);
		Если Спр1.НайтиЭлемент(ТекЭл) = 1 Тогда
			Спр1.Родитель = Группа2;
			Спр1.Записать();
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Конечно, здесь опубликован не весь программный код обработки для переноса элементов справочника. Но его можно увидеть, да и опробовать саму эту обработку, если скачать по ссылке. Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


Этот блог читают уже более 3000 человек - читай и ТЫ!
2 ответы

Ответить

Хотите присоединиться к обсуждению?
Не стесняйтесь вносить свой вклад!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *