Доброго времени суток, уважаемые посетители! На этом блоге мы уже выкладывали обработку, которая наглядно показывала, как удалить элементы справочника, в наименовании которых встречается введенная пользователем строка или как вставить рисунок с прозрачным фоном в таблицу. Сегодня мы рассмотрим, как программно перенести элементы справочника из одной группы в другую в системе 1C:Предприятие 7.7. Итак, приступим.

Воспользуемся следующим решением:

Процедура Перенести()
	СпрИмя = СокрЛП(ComboBox.ПолучитьЗначение(ComboBox.ТекущаяСтрока()));
	Список = СоздатьОбъект("СписокЗначений");
	Спр = СоздатьОбъект("Справочник." + СпрИмя);
	Кол = 0;
	Спр.ИспользоватьРодителя(Группа1);
	Спр.ВыбратьЭлементы();
	Пока Спр.ПолучитьЭлемент() = 1 Цикл
		Кол = Кол + 1;
		Список.ДобавитьЗначение(Спр.ТекущийЭлемент());
		Состояние(Спр.Код + " - " + Кол);
	КонецЦикла;
	Спр1 = СоздатьОбъект("Справочникю." + СпрИмя);
	Для к=1 По Список.РазмерСписка() Цикл
		ТекЭл = Список.ПолучитьЗначение(к);
		Если Спр1.НайтиЭлемент(ТекЭл) = 1 Тогда
			Спр1.Родитель = Группа2;
			Спр1.Записать();
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Понравилась ли вам обработка? Что можно изменить, что добавить? Не стесняйтесь делиться об этом в комментариях!


Этот блог читают уже более 3000 человек - читай и ТЫ!
2 ответы

Ответить

Хотите присоединиться к обсуждению?
Не стесняйтесь вносить свой вклад!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *