Здравствуйте, уважаемые читатели блога SoftMaker.kz! В статье «Для чего используется объединение результатов запросов в системе 1С:Предприятие 8?» было подробно рассказано об объединении запросов. Здесь приведён реальный пример реализации объединения для типовой конфигурации Управление торговым предприятием для Казахстана, редакция 1.0. 

Внешний вид отчета по резервам следующий:

Форма отчета по резервам с реализацией объединения запроса

Описание работы с отчётом по резервам

  1. Скачайте отчёт по ссылке в конце статьи.
  2. Затем откройте её в режиме 1С:Предприятие 8.
  3. Перейдите к пункту меню «Файл» | «Открыть…» (Ctrl+O).
  4. Установите необходимые для вас данные в полях отчёта.
  5. Нажмите кнопку «Сформировать».

Программный код отчёта по резервам товаров

Как показано в листинге кода ниже, чтобы вывести отчет используется механизм построителя отчета. При нажатии на кнопку «Сформировать» происходит вывод отчета в поле табличного документа.

Процедура КнопкаСформироватьНажатие(Кнопка)
	ЗаполнитьТекстЗапроса();
	Построитель.Параметры.Вставить("ДатаНач", ДатаНач);
	Построитель.Параметры.Вставить("ДатаКон", ДатаКон);
	Если Склад.Наименование <> "" Тогда
		Построитель.Параметры.Вставить("Склад", Склад);
	КонецЕсли;
	Если Номенклатура.Наименование <> "" Тогда
		Построитель.Параметры.Вставить("Номенклатура", Номенклатура);
	КонецЕсли;
	Построитель.Выполнить();
	ЭлементыФормы.ПолеТабличногоДокумента1.Очистить();
	Построитель.Вывести(ЭлементыФормы.ПолеТабличногоДокумента1);
КонецПроцедуры

В модуле формы отчёта приведен код процедуры ЗаполнитьТекстЗапроса, которая формирует текст запроса для формирования отчета по резервам с помощью объединения. Чтобы увидеть, как происходит формирование запроса, вы можете скачать и попробовать в работе отчёт по резервам. Вы также можете посмотреть обработку, в которой приводится небольшой пример того, как программно вывести табличное поле в табличный документ, используя построитель отчета.

ПОДПИСКА